What are the requirements to install the Yale Connect App?

In order to install the Yale Connect application you need:

  • A mobile device (Tablet o Smartphone) with iOS 13 or Android 7 operating systems or later versions.
  • A Wi-Fi® 2.4 Ghz network without any restrictions and no need of a proxy to access Internet.

The YaleConnect application can be downloaded from the Google Play (Android) or App Store (iOS). You can see the "Installation Instructions" in the Help site.